<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":5,"applicationTime":218,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81898334-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<title>GoldandBlack  -  Four-star Ben Carlson talks visits, timeline</title>
<meta content='GoldandBlack  -  Four-star Ben Carlson talks visits, timeline' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-28f7e9f8b5e36d846a0976742fba6bb1a7dd9adc2006371d3f80e9792d3b44c3.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ae47702e860d0208681b49a40d344e1f884d9a27b8119a9a66ea1c0cc6579d18.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="KrPGPuA2sJ9DpXW/MdrQdkphMBL++Yhrjm8+oMNVP5/zcrPrKVZKaYOMp/U4eUvGeEEYuTWCSjqPcOsyifSKKQ==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      var singleSiteApp = function() {
        return "false";
      };
  
      return {
        getPremiumIcon: getPremiumIcon,
        singleSiteApp: singleSiteApp
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/ktayiv2ipirclkdtvssa' property='og:image'>
<meta content='Four-star Ben Carlson discusses where he is in the recruiting process.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-08-07 09:55:22 -0500' property='article:published_time'>
<meta content='2019-08-07 09:55:23 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Ben Carlson' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "purdue.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='purdue contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .purdue #programming > h1 {
      background-color: #000000 !important; } }
  .purdue .wrapper-container .team-colors-line {
    background-color: #BB9207; }
  .purdue img.custom-premium-icon, .purdue .custom-premium-icon, .purdue img.custom-premium-white-icon, .purdue .custom-premium-white-icon,
  .purdue img.custom-premium-gallery-icon, .purdue .custom-premium-gallery-icon, .purdue .premium-icon-container {
    display: none; }
  .purdue .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .purdue .team-colors-line .color {
      width: 33.33%; }
    .purdue .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .purdue .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .purdue .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .purdue .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .purdue .team-colors-line.header {
      height: 6px; }
  .purdue > header .notification-link .count-container {
    background-color: #000000 !important; }
  .purdue > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .purdue > header .wrapper-container {
        border-bottom: 6px solid #BB9207 !important; } }
  .purdue > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .purdue > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .purdue > header .invalid-email-banner a:hover {
      color: #BB9207; }
  @media screen and (max-width: 767px) {
    .purdue > header .mobile-header {
      background-color: #BB9207 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .purdue > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .purdue > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .purdue > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .purdue > header .nav-row > ul,
    .purdue > header .third-nav {
      background-color: white !important; }
    .purdue > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .purdue > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #BB9207; }
  
  .site-secondary-background-color {
    background-color: #BB9207; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 0, 0, 0.4), rgba(0, 0, 0, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #000000;
    --secondary-color: #BB9207;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false,"Purdue")' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-black'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Purdue" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://purdue.rivals.com/"><img src="https://res-3.cloudinary.com/rivals/image/upload/njar9y3fovuyaja0aech" alt="Njar9y3fovuyaja0aech" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath + ctrl.utmParams }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://purdue.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;purdue&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://purdue.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;purdue&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733137,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Four-star Ben Carlson talks visits, timeline"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='rivals' name='twitter:site'>
<meta content='Four-star Ben Carlson talks visits, timeline' name='twitter:title'>
<meta content='Four-star Ben Carlson discusses where he is in the recruiting process.' name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ktayiv2ipirclkdtvssa' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":116,"legacy_id":892,"name":"GoldandBlack","friendly_name":"Purdue","annual_discount":null,"subdomain":"purdue","primary_color":"000000","secondary_color":"BB9207","font_color":"ffffff","short_name":"Purdue","maple_ncaaf_team_id":35,"maple_ncaaf_endpoint":"ncaaf/teams/ppj","maple_ncaab_team_id":474,"maple_ncaab_endpoint":"ncaab/teams/pau","maple_college_id":35,"google_analytics_id":"UA-81898334-1"}, true, 204, nil, {"id":163,"primary_color":"000000","secondary_color":"BB9207","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"Purdue","header_logo_cloudinary":"njar9y3fovuyaja0aech","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81898334-1","logo_background_shading":"black","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":false,"site_id":116,"created_at":"2016-11-23T13:38:45.449-06:00","updated_at":"2019-01-14T19:00:09.542-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"forums_link_url":"https://purdue.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5964f2edf3bdc926ec4f3729","aol_company_id":"595e96592a30cb7ee3e53955","ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":true,"follow_twitter_handle":"GoldandBlackcom","follow_fb_handle":"GoldandBlackcom","forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null,"custom_premium_icon_enabled":null,"email_logo_cloudinary":null},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, false, {"id":749,"user_id":227596,"site_id":174,"updated_at":"2018-02-27T19:14:18.860-06:00","publisher_name":"Eric Bossi","first_name":"Eric","last_name":"Bossi","site_title":"National Analyst","bio":"","twitter_handle":"ebosshoops","image_url":null,"publisher_name_and_title":"Eric Bossi, National Analyst","site_name":"Basketball Recruiting","site_short_name":"basketballrecruiting","has_edited_profile":true})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":469,"image_id":2549329,"url":"http://www.purdueu.com","position":1,"site_id":116,"created_at":"2019-04-16T13:20:28.637-05:00","updated_at":"2019-04-16T13:20:28.637-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/vipfsfjopy7c1ywoab0u"}' class='ad-one'></rv-custom-ad>
<rv-custom-ad ad='{"id":453,"image_id":2445226,"url":"http://www.purdueu.com","position":2,"site_id":116,"created_at":"2019-02-07T15:36:40.266-06:00","updated_at":"2019-02-25T08:39:44.427-06:00","image_url":"https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/baty1b5scbrof7njmrpx"}' class='ad-two'></rv-custom-ad>

<rv-forums ad-referer='https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits' base-api-url='https://Purdue.forums.rivals.com/' forums-url='https://purdue.forums.rivals.com' homepage='false' pub-ad='{"id":453,"image_id":2445226,"url":"http://www.purdueu.com","position":2,"site_id":116,"created_at":"2019-02-07T15:36:40.266-06:00","updated_at":"2019-02-25T08:39:44.427-06:00","image_url":"https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/baty1b5scbrof7njmrpx"}' size='size' space-id='2022733137' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits/printable' site-name='GoldandBlack'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-08-07 09:55:22 -0500') }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2066321/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Four-star Ben Carlson talks visits, timeline</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ktayiv2ipirclkdtvssa','https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto/ktayiv2ipirclkdtvssa')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ktayiv2ipirclkdtvssa" alt="Ktayiv2ipirclkdtvssa" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Ben Carlson (Nick Lucero/Rivals.com)</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Eric Bossi
&bull;
</span>
<a class='type-sm' href='{{editPath(subdomain)}}'>Basketball Recruiting</a>
<div class='type-sm'>
<a href='//twitter.com/ebosshoops' target='_blank'>@ebosshoops</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>National Analyst</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/ebosshoops'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='preview-container'>
<div class='article-preview'></div>
<div class='fade-container'>
<div class='article-fade'></div>
<div class='st__content-block st__content-block--text article-text'>
<p>LAS VEGAS -- Four-star Ben Carlson&#39;s summer wasn&#39;t like he&#39;s been used to. Luckily for him he&#39;s already in pretty good shape on the recruiting front as he starts to think future official visits.A s...</p>

</div>

</div>
</div>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>
You must be a member to read the full article. Subscribe now for instant access to all premium content.
</h3>
<div class='buttons'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=116?utm_source=Purdue&amp;utm_medium=on_site&amp;utm_campaign=article_upsell">Subscribe to GoldandBlack</a>
</div>
<div class='sign-in'>
Already have an account?
<a href="/users/sign_in">Log in</a>
</div>
</div>
<div class='value-props article-preview'>
<ul>
<li class='value-prop' ng-attr-id=''>
<div class='check'><?xml version="1.0" encoding="UTF-8"?>
<svg width="16px" height="11px" viewbox="0 0 16 11" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 54.1 (76490) - https://sketchapp.com -->
    <title>icn-check-mark</title>
    <desc>Created with Sketch.</desc>
    <g id="Style-Guide---Icons" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-181.000000, -1608.000000)" fill="#000000" id="icn-/-check-mark">
            <g transform="translate(173.000000, 1597.000000)">
                <polygon id="svg" points="22.3356362 11.2525907 23.6643638 12.7474093 13.9596278 21.3738414 8.29289322 15.7071068 9.70710678 14.2928932 14.0403722 18.6261586"></polygon>
            </g>
        </g>
    </g>
</svg></div>
<div class='prop-text'>Members-only forums</div>
</li>
<li class='value-prop' ng-attr-id=''>
<div class='check'><?xml version="1.0" encoding="UTF-8"?>
<svg width="16px" height="11px" viewbox="0 0 16 11" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 54.1 (76490) - https://sketchapp.com -->
    <title>icn-check-mark</title>
    <desc>Created with Sketch.</desc>
    <g id="Style-Guide---Icons" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-181.000000, -1608.000000)" fill="#000000" id="icn-/-check-mark">
            <g transform="translate(173.000000, 1597.000000)">
                <polygon id="svg" points="22.3356362 11.2525907 23.6643638 12.7474093 13.9596278 21.3738414 8.29289322 15.7071068 9.70710678 14.2928932 14.0403722 18.6261586"></polygon>
            </g>
        </g>
    </g>
</svg></div>
<div class='prop-text'>Predict prospect commits with FanFutureCast</div>
</li>
<li class='value-prop' ng-attr-id=''>
<div class='check'><?xml version="1.0" encoding="UTF-8"?>
<svg width="16px" height="11px" viewbox="0 0 16 11" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 54.1 (76490) - https://sketchapp.com -->
    <title>icn-check-mark</title>
    <desc>Created with Sketch.</desc>
    <g id="Style-Guide---Icons" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-181.000000, -1608.000000)" fill="#000000" id="icn-/-check-mark">
            <g transform="translate(173.000000, 1597.000000)">
                <polygon id="svg" points="22.3356362 11.2525907 23.6643638 12.7474093 13.9596278 21.3738414 8.29289322 15.7071068 9.70710678 14.2928932 14.0403722 18.6261586"></polygon>
            </g>
        </g>
    </g>
</svg></div>
<div class='prop-text'>Exclusive highlights and interviews</div>
</li>
<li class='value-prop' ng-attr-id=''>
<div class='check'><?xml version="1.0" encoding="UTF-8"?>
<svg width="16px" height="11px" viewbox="0 0 16 11" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 54.1 (76490) - https://sketchapp.com -->
    <title>icn-check-mark</title>
    <desc>Created with Sketch.</desc>
    <g id="Style-Guide---Icons" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-181.000000, -1608.000000)" fill="#000000" id="icn-/-check-mark">
            <g transform="translate(173.000000, 1597.000000)">
                <polygon id="svg" points="22.3356362 11.2525907 23.6643638 12.7474093 13.9596278 21.3738414 8.29289322 15.7071068 9.70710678 14.2928932 14.0403722 18.6261586"></polygon>
            </g>
        </g>
    </g>
</svg></div>
<div class='prop-text'>Exclusive coverage of Rivals Camp Series</div>
</li>
<li class='value-prop' ng-attr-id=''>
<div class='check'><?xml version="1.0" encoding="UTF-8"?>
<svg width="16px" height="11px" viewbox="0 0 16 11" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 54.1 (76490) - https://sketchapp.com -->
    <title>icn-check-mark</title>
    <desc>Created with Sketch.</desc>
    <g id="Style-Guide---Icons" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-181.000000, -1608.000000)" fill="#000000" id="icn-/-check-mark">
            <g transform="translate(173.000000, 1597.000000)">
                <polygon id="svg" points="22.3356362 11.2525907 23.6643638 12.7474093 13.9596278 21.3738414 8.29289322 15.7071068 9.70710678 14.2928932 14.0403722 18.6261586"></polygon>
            </g>
        </g>
    </g>
</svg></div>
<div class='prop-text'>Breaking recruiting news</div>
</li>
</ul>

</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits/printable' site-name='GoldandBlack'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='{"id":453,"image_id":2445226,"url":"http://www.purdueu.com","position":2,"site_id":116,"created_at":"2019-02-07T15:36:40.266-06:00","updated_at":"2019-02-25T08:39:44.427-06:00","image_url":"https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/baty1b5scbrof7njmrpx"}' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":116,"legacy_id":892,"name":"GoldandBlack","friendly_name":"Purdue","annual_discount":null,"subdomain":"purdue","primary_color":"000000","secondary_color":"BB9207","font_color":"ffffff","short_name":"Purdue","maple_ncaaf_team_id":35,"maple_ncaaf_endpoint":"ncaaf/teams/ppj","maple_ncaab_team_id":474,"maple_ncaab_endpoint":"ncaab/teams/pau","maple_college_id":35,"google_analytics_id":"UA-81898334-1"}' twitter-feed='{"id":116,"site_id":116,"handle":"GoldandBlackcom","list_name":"goldandblack-com","created_at":"2016-02-01T12:25:20.180-06:00","updated_at":"2016-02-01T19:30:26.188-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits/printable' site-name='GoldandBlack'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733137', 'https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Four-star Ben Carlson talks visits, timeline";
  _sf_async_config.sections = 'content,content-basketball,content-basketball-premium,content-article,cross-viewed';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("Purdue", 2066321, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":469,"image_id":2549329,"url":"http://www.purdueu.com","position":1,"site_id":116,"created_at":"2019-04-16T13:20:28.637-05:00","updated_at":"2019-04-16T13:20:28.637-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/vipfsfjopy7c1ywoab0u"}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</li>
</ul>
<div class='logo-container'>
<div class='footer-logo'></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733137",
    c7: "https://purdue.rivals.com/news/four-star-ben-carlson-talks-visits"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fpurdue.rivals.com%2Fnews%2Ffour-star-ben-carlson-talks-visits&c5=2022733137&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
